# Latest

**URL:** https://community.replicated.com/latest.md?page=2

[Latest](https://community.replicated.com/latest.md) · [Categories](https://community.replicated.com/categories.md) · [Tags](https://community.replicated.com/tags.md)

**Page:** 3

---

## [Delete old application releases](https://community.replicated.com/t/delete-old-application-releases/1508)

<div class="topic-metadata">

**Author:** [@GerardNguyen](https://community.replicated.com/u/GerardNguyen)\
**Replies:** 2\
**Last updated:** [June 11, 2025, 2:01pm UTC](https://community.replicated.com/t/delete-old-application-releases/1508 "2025-06-11T14:01:24Z")

</div>

KOTS Admin Console does not natively provide a way to delete application releases. This can cause performance issues as the number of application archives grows, potentially leading to out-of-memory (OOM) event, disk spa…

---

## [Resolving KOTS "Pending Download" Issues](https://community.replicated.com/t/resolving-kots-pending-download-issues/1540)

<div class="topic-metadata">

**Author:** [@Evans\_Mungai](https://community.replicated.com/u/Evans_Mungai)\
**Replies:** 2\
**Last updated:** [June 25, 2025, 9:00am UTC](https://community.replicated.com/t/resolving-kots-pending-download-issues/1540 "2025-06-25T09:00:27Z")

</div>

Overview When KOTS (Kubernetes Off-The-Shelf) is configured for automatic updates, failed downloads due to failure modes such as Docker rate limits can create “Pending download” sequences in the release history. These or…

---

## [Support bundles in helm-cli installs - Guidelines and best practices](https://community.replicated.com/t/support-bundles-in-helm-cli-installs-guidelines-and-best-practices/1546)

<div class="topic-metadata">

**Author:** [@Ash\_Jones](https://community.replicated.com/u/Ash_Jones)\
**Replies:** 0\
**Last updated:** [June 19, 2025, 2:17pm UTC](https://community.replicated.com/t/support-bundles-in-helm-cli-installs-guidelines-and-best-practices/1546 "2025-06-19T14:17:06Z")

</div>

We’ve been working on some best-practices and guidance on how to work with support-bundle and preflight specs over on our platform-examples repository! This document attempts to set a pattern for working with support bu…

---

## [How to: Use CMX to simulate installs with Proxy's](https://community.replicated.com/t/how-to-use-cmx-to-simulate-installs-with-proxys/1545)

<div class="topic-metadata">

**Author:** [@Joe\_Martinez](https://community.replicated.com/u/Joe_Martinez)\
**Replies:** 0\
**Last updated:** [June 18, 2025, 5:33pm UTC](https://community.replicated.com/t/how-to-use-cmx-to-simulate-installs-with-proxys/1545 "2025-06-18T17:33:34Z")

</div>

CMX Proxy guide What You Need 2 CMX VMs that are on the same network One will be the proxy server, one will be the target for installation Step 1: Set Up Proxy VM Spin up a CMX VM replicated vm create --distribution ub…

---

## [New release of ReplBAC, my Vendor Portal team management tool](https://community.replicated.com/t/new-release-of-replbac-my-vendor-portal-team-management-tool/1543)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 17, 2025, 5:29pm UTC](https://community.replicated.com/t/new-release-of-replbac-my-vendor-portal-team-management-tool/1543 "2025-06-17T17:29:06Z")

</div>

In Simplified Role Management for the Replicated Platform I posted about ReplBAC, a utility I wrote for managing Vendor Portal roles in an infrastructure-as-code style. ReplBAC eliminates the tedious clicking and manual…

---

## [Troubleshoot Preflight failures with HTTPS Proxy](https://community.replicated.com/t/troubleshoot-preflight-failures-with-https-proxy/1542)

<div class="topic-metadata">

**Author:** [@GerardNguyen](https://community.replicated.com/u/GerardNguyen)\
**Replies:** 0\
**Last updated:** [June 17, 2025, 2:28am UTC](https://community.replicated.com/t/troubleshoot-preflight-failures-with-https-proxy/1542 "2025-06-17T02:28:01Z")

</div>

When installing applications using Replicated Embedded Cluster in environments with --http-proxy, --https-proxy configurations, you may encounter preflight failures that prevent successful installation. This guide walks …

---

## [Testing Kubernetes Network Connectivity with the Goldpinger Troubleshoot Collector](https://community.replicated.com/t/testing-kubernetes-network-connectivity-with-the-goldpinger-troubleshoot-collector/1541)

<div class="topic-metadata">

**Author:** [@Joe\_Martinez](https://community.replicated.com/u/Joe_Martinez)\
**Replies:** 0\
**Last updated:** [June 13, 2025, 9:03pm UTC](https://community.replicated.com/t/testing-kubernetes-network-connectivity-with-the-goldpinger-troubleshoot-collector/1541 "2025-06-13T21:03:16Z")

</div>

Testing Kubernetes Network Connectivity with the Goldpinger Troubleshoot Collector Network connectivity issues are among the most challenging problems to diagnose in Kubernetes clusters. Pods can’t reach each other, serv…

---

## [Why you should create \`HelmChart\` resources for your Helm-only releases](https://community.replicated.com/t/why-you-should-create-helmchart-resources-for-your-helm-only-releases/1539)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 13, 2025, 3:38pm UTC](https://community.replicated.com/t/why-you-should-create-helmchart-resources-for-your-helm-only-releases/1539 "2025-06-13T15:38:19Z")

</div>

When talking with vendors using Replicated, it sometimes comes up that they should create HelmChart resources even when they only ever plan for their customers to install with Helm. This recommendation often raises eye…

---

## [How backups are scheduled when using Velero with Kotsadm](https://community.replicated.com/t/how-backups-are-scheduled-when-using-velero-with-kotsadm/1535)

<div class="topic-metadata">

**Author:** [@Balint\_Csonka](https://community.replicated.com/u/Balint_Csonka)\
**Replies:** 2\
**Last updated:** [June 13, 2025, 6:27am UTC](https://community.replicated.com/t/how-backups-are-scheduled-when-using-velero-with-kotsadm/1535 "2025-06-13T06:27:48Z")

</div>

Hi! We have been reviewing our backup solution using Velero with Kotsadm, where we have configured schedules on the Snapshots tab. I have expected this configuration to create a Schedule (velero.io/v1/schedules) custom…

---

## [Simplified Role Management for the Replicated Platform](https://community.replicated.com/t/simplified-role-management-for-the-replicated-platform/1538)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 12, 2025, 6:51pm UTC](https://community.replicated.com/t/simplified-role-management-for-the-replicated-platform/1538 "2025-06-12T18:51:08Z")

</div>

A few days ago, a question came up on a call about managing Replicated Vendor Portal roles in an infrastructure-as-code style. We do have a Terraform provider that’s focused on testing scenarios, but it doesn’t focus on …

---

## [Troubleshooting kubectl exec and logs Commands After Certificate Renewal](https://community.replicated.com/t/troubleshooting-kubectl-exec-and-logs-commands-after-certificate-renewal/1534)

<div class="topic-metadata">

**Author:** [@Joe\_Martinez](https://community.replicated.com/u/Joe_Martinez)\
**Replies:** 0\
**Last updated:** [June 11, 2025, 3:26pm UTC](https://community.replicated.com/t/troubleshooting-kubectl-exec-and-logs-commands-after-certificate-renewal/1534 "2025-06-11T15:26:15Z")

</div>

Problem Description After automatic certificate renewal on kURL clusters running Kubernetes versions prior to 1.29, you may experience issues where certain kubectl commands fail while others continue to work normally. S…

---

## [Verifying Image Signatures with Preflight Checks](https://community.replicated.com/t/verifying-image-signatures-with-preflight-checks/1529)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 4, 2025, 4:46pm UTC](https://community.replicated.com/t/verifying-image-signatures-with-preflight-checks/1529 "2025-06-04T16:46:59Z")

</div>

A question came up this morning about checking image signatures when distributing software through the Replicated Platform. This is something I’ve tackled before with a solution I’m particularly fond of. While end custo…

---

## [Setting up your system for working with the Replicated Platform](https://community.replicated.com/t/setting-up-your-system-for-working-with-the-replicated-platform/1528)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 3, 2025, 7:22pm UTC](https://community.replicated.com/t/setting-up-your-system-for-working-with-the-replicated-platform/1528 "2025-06-03T19:22:13Z")

</div>

This morning I was helping someone evaluation Replicated and they mentioned they’d upgrade their laptop since our last session. This meant they’d lost all of the tools we’d set up for interacting with the Replicated Plat…

---

## [Custom domains hanging at the TLS validation step](https://community.replicated.com/t/custom-domains-hanging-at-the-tls-validation-step/1526)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 2, 2025, 3:30pm UTC](https://community.replicated.com/t/custom-domains-hanging-at-the-tls-validation-step/1526 "2025-06-02T15:30:30Z")

</div>

I helped someone solve an frustrating issue with their custom domain creation this morning, and wanted to share the solution for anyone else stumbling upon it. All four domains were stuck on Step 4: “TLS cert creation ve…

---

## [Capturing the release name and namespace your customer used to install your Helm chart](https://community.replicated.com/t/capturing-the-release-name-and-namespace-your-customer-used-to-install-your-helm-chart/1527)

<div class="topic-metadata">

**Author:** [@crdant](https://community.replicated.com/u/crdant)\
**Replies:** 0\
**Last updated:** [June 2, 2025, 4:05pm UTC](https://community.replicated.com/t/capturing-the-release-name-and-namespace-your-customer-used-to-install-your-helm-chart/1527 "2025-06-02T16:05:27Z")

</div>

A customer exploring Replicated had a smart question today: “How can I show accurate uninstall instructions in my support portal?” The problem is that install docs show a default release name, but customers may chose to…

---

## [How to: Roll Out License Custom Fields Value Changes](https://community.replicated.com/t/how-to-roll-out-license-custom-fields-value-changes/1524)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 27, 2025, 11:25pm UTC](https://community.replicated.com/t/how-to-roll-out-license-custom-fields-value-changes/1524 "2025-05-27T23:25:46Z")

</div>

When managing customer licenses in the Replicated Vendor Portal, each license record contains several built-in fields. These include customer-specific properties such as: Customer name Vendor Portal channel assignment C…

---

## [Enable ssl for replicated-sdk pod](https://community.replicated.com/t/enable-ssl-for-replicated-sdk-pod/1522)

<div class="topic-metadata">

**Author:** [@manish.s](https://community.replicated.com/u/manish.s)\
**Replies:** 3\
**Last updated:** [May 22, 2025, 1:23pm UTC](https://community.replicated.com/t/enable-ssl-for-replicated-sdk-pod/1522 "2025-05-22T13:23:04Z")

</div>

Edited We’re running the Replicated pod on our cluster and have a requirement to enable secure HTTPS communication between pods. Currently, the Replicated pod communicates over HTTP on port 3000. Here, you can see that…

---

## [How to: uninstall a Helm Chart from Embedded Cluster Configuration and the Cluster (EC 1.x.x)](https://community.replicated.com/t/how-to-uninstall-a-helm-chart-from-embedded-cluster-configuration-and-the-cluster-ec-1-x-x/1521)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 21, 2025, 3:14am UTC](https://community.replicated.com/t/how-to-uninstall-a-helm-chart-from-embedded-cluster-configuration-and-the-cluster-ec-1-x-x/1521 "2025-05-21T03:14:27Z")

</div>

If you need to install Helm charts before your application and as part of the Embedded Cluster itself, you can do this with Helm extensions. However, after changes to your application, there may be cases where you want …

---

## [How to: Troubleshooting openebs-localpv-provisioner Failures in kURL](https://community.replicated.com/t/how-to-troubleshooting-openebs-localpv-provisioner-failures-in-kurl/1520)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 15, 2025, 6:42am UTC](https://community.replicated.com/t/how-to-troubleshooting-openebs-localpv-provisioner-failures-in-kurl/1520 "2025-05-15T06:42:18Z")

</div>

After installing your kURL cluster, you might encounter an issue where the openebs-localpv-provisioner pod keeps failing or restarting. Consequently, related Persistent Volume Claims (PVCs) remain in the Pending state wi…

---

## [How to: Choose the Right --network-interface to Solve ‘Timed Out Waiting’ Errors During Embedded Cluster Installation](https://community.replicated.com/t/how-to-choose-the-right-network-interface-to-solve-timed-out-waiting-errors-during-embedded-cluster-installation/1519)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 15, 2025, 4:28am UTC](https://community.replicated.com/t/how-to-choose-the-right-network-interface-to-solve-timed-out-waiting-errors-during-embedded-cluster-installation/1519 "2025-05-15T04:28:57Z")

</div>

When installing a new Embedded Cluster using your installation script, you may encounter timeout errors with messages displayed in the terminal, such as: timed out waiting for openebs-localpv-provisioner to deploy infr…

---

## [View saved images in an airgap bundle](https://community.replicated.com/t/view-saved-images-in-an-airgap-bundle/1518)

<div class="topic-metadata">

**Author:** [@GerardNguyen](https://community.replicated.com/u/GerardNguyen)\
**Replies:** 0\
**Last updated:** [May 13, 2025, 7:02am UTC](https://community.replicated.com/t/view-saved-images-in-an-airgap-bundle/1518 "2025-05-13T07:02:26Z")

</div>

If you have an airgap bundle and need to inspect the container images without extracting the entire bundle, you can use the following commands. Prerequisites tar CLI installed Inspecting Images in an Airgap Bundle Sta…

---

## [How to Fix "&" Operator Causing Pod CrashLoopBackOff in Kubernetes](https://community.replicated.com/t/how-to-fix-operator-causing-pod-crashloopbackoff-in-kubernetes/1517)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 13, 2025, 6:22am UTC](https://community.replicated.com/t/how-to-fix-operator-causing-pod-crashloopbackoff-in-kubernetes/1517 "2025-05-13T06:22:16Z")

</div>

If you’re encountering the following error: job \*\*\* failed: BackoffLimitExceeded pod \*\*\* CrashLoopBackOff You might be facing a CrashLoopBackOff caused by incorrect use of the & operator in your pod command . The Prob…

---

## [Fix for "Permission Denied" Error When Starting etcd in Embedded Cluster](https://community.replicated.com/t/fix-for-permission-denied-error-when-starting-etcd-in-embedded-cluster/1516)

<div class="topic-metadata">

**Author:** [@Evans\_Mungai](https://community.replicated.com/u/Evans_Mungai)\
**Replies:** 0\
**Last updated:** [May 12, 2025, 5:12pm UTC](https://community.replicated.com/t/fix-for-permission-denied-error-when-starting-etcd-in-embedded-cluster/1516 "2025-05-12T17:12:46Z")

</div>

If you’re encountering the following error during your Embedded Cluster installation: Failed to start: fork/exec \<data-dir\>/k0s/bin/etcd: permission denied component=etcd You’re not alone—this is a known issue that typ…

---

## [How to fix failed to create fsnotify watcher Error When Running support-bundle](https://community.replicated.com/t/how-to-fix-failed-to-create-fsnotify-watcher-error-when-running-support-bundle/1514)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [May 7, 2025, 5:31am UTC](https://community.replicated.com/t/how-to-fix-failed-to-create-fsnotify-watcher-error-when-running-support-bundle/1514 "2025-05-07T05:31:56Z")

</div>

If you encounter errors when creating a support bundle or viewing logs in a Kubernetes cluster, such as: kubectl logs output: failed to create fsnotify watcher: too many open files pod log from support bundle shows: fa…

---

## [Kustomize render failures: mapping key already defined](https://community.replicated.com/t/kustomize-render-failures-mapping-key-already-defined/1512)

<div class="topic-metadata">

**Author:** [@GerardNguyen](https://community.replicated.com/u/GerardNguyen)\
**Replies:** 0\
**Last updated:** [May 1, 2025, 6:17am UTC](https://community.replicated.com/t/kustomize-render-failures-mapping-key-already-defined/1512 "2025-05-01T06:17:20Z")

</div>

When saving configuration changes in the KOTS Admin Console configuration screen, you may encounter the following error failed to render archive directory By inspecting the kotsadm pod logs, you might see an error stack…

---

## [How to Fix "client rate limiter Wait returned an error" in Kubernetes](https://community.replicated.com/t/how-to-fix-client-rate-limiter-wait-returned-an-error-in-kubernetes/1511)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 0\
**Last updated:** [April 30, 2025, 11:45pm UTC](https://community.replicated.com/t/how-to-fix-client-rate-limiter-wait-returned-an-error-in-kubernetes/1511 "2025-04-30T23:45:23Z")

</div>

The Problem When trying to collect logs or run support bundles in Kubernetes, you might encounter this error: failed to get log stream: client rate limiter Wait returned an error: context deadline exceeded This happens…

---

## [API for extacting Team and RBAC details](https://community.replicated.com/t/api-for-extacting-team-and-rbac-details/1507)

<div class="topic-metadata">

**Author:** [@Sammy\_Samuels](https://community.replicated.com/u/Sammy_Samuels)\
**Replies:** 1\
**Last updated:** [April 29, 2025, 12:31am UTC](https://community.replicated.com/t/api-for-extacting-team-and-rbac-details/1507 "2025-04-29T00:31:15Z")

</div>

Are there APIs that can be leveraged to pull information including a list of team members and their assigned roles, and another to pull the roles with their current permissions?

---

## [How do I archive/unarchive a license?](https://community.replicated.com/t/how-do-i-archive-unarchive-a-license/1044)

<div class="topic-metadata">

**Author:** [@Mariel\_Wilding](https://community.replicated.com/u/Mariel_Wilding)\
**Replies:** 1\
**Last updated:** [April 28, 2025, 2:59am UTC](https://community.replicated.com/t/how-do-i-archive-unarchive-a-license/1044 "2025-04-28T02:59:34Z")

</div>

How do I archive a license? When you archive a license in the vendor portal, it is hidden in the default license search and becomes read-only. Archival does not affect the utility of license files downloaded before the …

---

## [How to transfer a member between teams in the Vendor Portal](https://community.replicated.com/t/how-to-transfer-a-member-between-teams-in-the-vendor-portal/1504)

<div class="topic-metadata">

**Author:** [@Dexter\_Yan](https://community.replicated.com/u/Dexter_Yan)\
**Replies:** 1\
**Last updated:** [April 21, 2025, 11:51am UTC](https://community.replicated.com/t/how-to-transfer-a-member-between-teams-in-the-vendor-portal/1504 "2025-04-21T11:51:08Z")

</div>

If a user belongs to a team that is no longer active within your organization, you can transfer this user to a new team. For example, if your user with email address staff@test.com is currently a member of the test team…

---

## [Troubleshoot OpenEBS to Rook-Ceph storage migrations](https://community.replicated.com/t/troubleshoot-openebs-to-rook-ceph-storage-migrations/1505)

<div class="topic-metadata">

**Author:** [@GerardNguyen](https://community.replicated.com/u/GerardNguyen)\
**Replies:** 0\
**Last updated:** [April 17, 2025, 5:40am UTC](https://community.replicated.com/t/troubleshoot-openebs-to-rook-ceph-storage-migrations/1505 "2025-04-17T05:40:20Z")

</div>

In kURL installations, the migration from OpenEBS (non-HA) storage to Rook-Ceph (HA) is automatically handled by the kURL EKCO operator. This migration process is triggered when: At least 3 nodes are available (meeting…

[Previous page](https://community.replicated.com/latest.md?page=1)

[Next page](https://community.replicated.com/latest.md?page=3)
