Native: Is it possible to require a minimum version of Docker for a specific app release?

Yes, by specifying the version in host_requirements

An example can be found here.