Cannot upgrade kubernetes version to 1.127 as longhorn 1.3.1 doesn't support it

We have customers running on kubernetes version 1.23 along with longhorn 1.3.1 (latest kurl supported) and we wanted to upgrade the kubernetes version to 1.27 but when I am trying to build the kubernetes installer spec it show the error “Error: Longhorn versions <= 1.4.0 are not compatible with Kubernetes versions 1.25+”.

Is there any workaround for this issue ??

Unfortunately there is no workaround here since we deprecated Longhorn add-on on March 27, 2023 and with that we are no longer releasing new versions of this add-on.

The only thing left is to migrate your add-on to another CSI add-on. For more on that please refer to these guide. CSI add-on migrations are taken care of by the kURL installer. If you use pinned versions, please ensure you have the latest release.

For more on the reasons why we deprecated the add-on please read through this blog post

Thanks @Evans_Mungai but we don’t want to migrate to rook-ceph as we have faced lot of issues with rook-ceph in the past and it also needs an additional block device to be available.