Is Sonatype Nexus Repository 3 supported as a private docker registry?


We have a customer that has Sonatype Nexus Repository 3 and they want to use it as a private docker registry. We have an air-gapped existing cluster installation so we are forced to use a private registry to deploy the app. We have tried using what they have (the Nexus 3) and we keep getting 404 when pushing. Do you support this? Any idea what is going wrong? Any setup advice if you have worked with this in the past?


We don’t have specific documentation saying that we support that particular registry, but in some registries that do not support a “Create repo on push” feature, it’s necessary to make sure the repo names exist before pushing images into them.

If you’re using the airgap method kubectl kots push-images to push the images to the registry, try making sure that the repos exist first.

Here’s a related Community article for making sure the images get pushed into a private registry before installation: How can I separate the "push images" and "deploy" steps of installing an application using Replicated?

1 Like

@adamancini is correct. We had faced same issue with AWS ECR. So we had to create the repository beforehand.