Helm Installation - unable to locate tags in provided repository

Great question from last week

Something seems to have changed recently – I’ve been making changes to a chart for a Helm Installation with the Replicated SDK but they’re not showing up when I create a new release with replicated release create and then I run helm upgrade in my dev cluster. I tried creating a new channel to see if that would help, but any new channels I create are refusing to deploy anything. I even tried with a simple nginx chart, and I’m still can’t get helm install or helm upgrade to work.

The error I get from the Helm CLI is

Error: INSTALLATION FAILED: Unable to locate any tags in provided repository:

I’ve tried this on the replicated SDK version v0.0.1-beta.4 and v0.0.1-beta.3

This may be because Helm filters out pre-releases by default when searching for the chart to install. If the channel only contains prerelease charts, then you will also need to pass the --version flag to Helm. You can pass the exact chart version to this flag if it’s known and Helm will install it. However, if you would like to just install the latest version, you can pass --devel or --version '>0.0.0-0', which will cause Helm to include all releases (including prereleases) in its search.

1 Like